Unofficial Gravis Ultrasound OS/2 Driver (V0.2)

PMShell 0 65 05.12 14:35

Unofficial Gravis Ultrasound OS/2 Driver (V0.2)



1. Introduction.

     This is a second pass at GUS physical driver for OS/2 MMPM. It has

   just basic WAV playing capability. It works in conjunction with

   the Digital Audio player, the Digital Video player, and system sounds.


2. Installation.

     Simply unzip the file into a directory and run MINSTALL. It does

   the rest. You are given the choice of letting MINSTALL change

   your CONFIG.SYS. I wouldn't let it do that. Let it create a

   test file in \MMOS2 and compare that with your config.sys file

   to make sure nothing went wrong. Besides you may want to change

   the base and/or interrupt assignments first.


   The base and irq defaults are what work for me. You may want

   to change them (the DMA in particular).  The entry for 

   AUDIOVDD.SYS does not have the correct path name. You will

   have to correct this manually.


   The install file creates a wave player object in the multimedia

   folder. If the GUS is installed as a second (or third..) MMPM

   wave device, the the parameter field in its settings has to

   be modfied to include "Waveaudio0n", where n is the number of

   GUS device. Generally this would be Waveaudio02.


3. Known bugs.

   a. It doesn't record.  Later!

   b. Clicks. They can get annoying, but, from what I heard, fixing

      them everywhere could be a lifelong job. This release seems to

      be significantly better than 0.1 (in terms of clicks). 

      Trial and error seems to be the primary method of fixing such

      noises.

   c. MIDI is not supported. This will take a while!

   g. It does not play stereo WAVs properly. As a stopgap measure,

      the left channel is played on both channels.


4. Feedback.

     This is a first pass and I wanted to get something out to

   give everyone hope.  I know about enough problems to keep me

   busy for a while. So please, think before sending me a message

   telling me about something in the known bugs list. In fact, until

   I get out a 1.0 release, could we limit negative feedback to

   show-stoppers.  Also, I have a 486DLC system. I have had no other

   opportunities to try this on other systems. There is a chance that

   it will not run on your system because of some incompatibility I

   didn't anticipate.  Please be patient with this sort of problem, as I

   have limited resources to deal with different machine configurations.

   So far the only know imcompatibility was with a multi-processor

   system running the SMP beta.

   

   The following e-mail address is my work address.  I might have

   some problems if a huge amount of mail starting appearing, so

   think first.


   On the other hand, as an aid to deciding if a problem is

   configuration related, a note describing your successful

   use of the driver would be appreciated, if accompanied with

   a description of your configuration.


   The address to reach me is ernst@tymnet.com (yes, in real life,

   I work on software for the Tymnet Public Data Network. I do X.25

   stuff and 680x0 based firmware.)


Comments

Category
State
  • 현재 접속자 56 명
  • 오늘 방문자 192 명
  • 어제 방문자 670 명
  • 최대 방문자 934 명
  • 전체 방문자 269,727 명
  • 전체 게시물 461 개
  • 전체 댓글수 153 개
  • 전체 회원수 22 명
- 예전 사이트 : 2011 eComStation
- 쇼핑몰 : Softbox
Facebook Twitter GooglePlus KakaoStory NaverBand